Welcome to
the forums at bobdunsire.com
bobdunsire.com forums bobdunsire.com forums
You can reset your password by going here. Be sure to try your current email and any email addresses you may have had in the past.
Otherwise please use the Contact Us link at the bottom of the forums. In order to help you, please provide the following info: Your Display Name from the old forum and any possible email addresses you would have used before. Without that info we cannot locate your account.


Go Back   Bob Dunsire Bagpipe Forums > General Discussion > Do It Yourself (DIY)
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Do It Yourself (DIY) Making and repairing of instruments, accessories, and more.

Platinum Sponsors
Reply
 
Thread Tools
Old 03-22-2017, 06:56 PM   #41
Gassy
Forum Regular
 
Join Date: Feb 2015
Location: Australia
Posts: 155
Default Re: eChanter v3 released

Oh? I only looked at the switch test code which looks for a low, I assumed that applied to the main code. I shall read more!
Gassy is offline   Reply With Quote
Gold Sponsor
Old Yesterday, 05:33 PM   #42
mjd
Forum Member - Shy or Quiet
 
Join Date: Mar 2017
Location: Freehold, NJ
Posts: 1
Default Re: eChanter v3 troubleshooting

I am wondering if anyone has any advice. I am a novice programmer and beginner piper so I apologize in advance if I am missing something obvious. I am having trouble getting the echanter (v3) to work. I downloaded the sketch to an arduino, and attempt to test the code using jumper cables plugged into the proper pin locations as captouch sensors

When I touch the sensors, I can get the pin 2 captouch sensor to and play note 9. It also works when the pin 2 and 3 are touched simultaneously as shown from the Serial Monitor display (with note_detected and note_playing printed along with sensor, cycles and fmap variables).

Sensor::3::17 TOUCHED--fmap--0--note_detected--8--note_playing--8
Sensor::2::17 TOUCHED--fmap--2--note_detected--8--note_playing--8


However, when I try and touch more than that, I start to continuously get a tone (note 0) which I think is the grace note tone. You can see the serial readout when I touch three pins below.

Sensor::4::17 TOUCHED--fmap--0--note_detected--0--note_playing--0
Sensor::3::17 TOUCHED--fmap--4--note_detected--0--note_playing--0
Sensor::2::17 TOUCHED--fmap--6--note_detected--0--note_playing--0


I have altered the control rate variable to a setting of 64, and changed the captouch trigger setting to 3, and by doing so I can get it to read the note for sensors 4, 3 and 2 simultaneously, but after that I just get note zero again (as shown below).

Sensor::6::17 TOUCHED--fmap--0--note_detected--0--note_playing--0
Sensor::5::17 TOUCHED--fmap--16--note_detected--0--note_playing--0
Sensor::4::17 TOUCHED--fmap--24--note_detected--0--note_playing--0
Sensor::3::17 TOUCHED--fmap--28--note_detected--0--note_playing--0
Sensor::2::17 TOUCHED--fmap--30--note_detected--0--note_playing--0


I am at a loss of what to do to troubleshoot the problem. It seems as if the sensor touches are registered properly but the note detected and note playing variables stay on note zero.

If anyone can help I would greatly appreciate it. Regardless of my difficulties, its a great project!

Thanks,
mjd
mjd is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Silver Sponsor

All times are GMT -7. The time now is 01:46 PM.